railsでpostgresを入れ替えたらsocketでエラーになったとき

0pt   2018-08-10 15:48
IT技術情報局

あまりないケースでしょうが、遭遇している人がいないとは限らないので・・・

rails+postgresでアプリを構築して、途中でpostgresをパッケージインストールからソースからのインストールのものに移行したところ
ソケット /var/run/postgresql/.s.PGSQL.5432
にないよ、となってエラーになる場合

・ソース版のデフォルトではsocketは/tmp
・新たにrails newしたものはつながる

という状況だったので、pg(Gemfile.lockに出てくるバージョン)を再インスト-ルで復旧しました。

多分ソース版からパッケージへの移行も同じかと思います。

Source: rails tag

   ITアンテナトップページへ
情報処理/ITの話題が沢山。